Project

General

Profile

Feature #233

DMARC dnsconf

Added by julienmalik over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Email
Target version:

Description

the dnsconf command should also specify, in addition to SPF and DKIM, a DMARC record.
See https://dmarc.org/ for the specifications.

See https://support.google.com/mail/answer/81126?p=ipv6_authentication_error&rd=1#authentication
mail-tester recognize it and tells if it is present or not.

Here is a sample working record (which does not implement anything usefull, just saying to do nothing w.r.t DMARC):

_dmarc 10800 IN TXT "v=DMARC1; p=none"

History

#1 Updated by moul over 1 year ago

  • Description updated (diff)

#2 Updated by moul over 1 year ago

  • Category set to Email

#4 Updated by opi over 1 year ago

  • Status changed from New to Resolved
  • Target version set to 2.4

Done in https://github.com/YunoHost/yunohost/commit/4a787da4402ceeac85ca72f7c20ed38328228f6c ;
It's just a basic and dummy DMARC support.

DMARC could be a lot more complicated (ex: v=DMARC1; adkim=s; aspf=r; p=none; rua=mailto:foo@example.com;), but I don't know by now what settings YunoHost might use.

#5 Updated by moul over 1 year ago

The issue is not crossed on the roadmap.

#6 Updated by Bram over 1 year ago

That's because right now only "closed" issues are crossed for whatever reason.

Also available in: Atom PDF